02 Altima 2.5 with no heat, HELP!!! - Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old Jan 10th, 2007, 01:18 PM
Sorta-Newbie
 
Join Date: Oct 2005
Location: Cincinnati
Posts: 18
02 Altima 2.5 with no heat, HELP!!!

The only time i have heat is when i'm on the highway.

I just changed out the thermostat, its had a coolant flush. What else can i do?

I would prefer not to take it to the dealer.

Last edited by blacktruckryder; Jan 10th, 2007 at 01:48 PM.
blacktruckryder is offline  
Sponsored Links
Advertisement
 
#2 Old Jan 10th, 2007, 09:01 PM
Nissan Technician
 
metro273's Avatar
 
Join Date: Sep 2005
Location: Western Burbs of Chicago
Posts: 826
Sounds to me like you MIGHT have a blown head gasket? This is a common issue with the '02-'04 Altimas with the 2.5s. Take it to a Nissan dealership for a correct diagnosis or you'll do what most people do on here and try to fix it themselves and realize that they can't, so it ends up going to a Nissan dealership anyways...

BTW, Have you correctly bled the trapped air out of the cooling system?

Last edited by metro273; Jan 10th, 2007 at 09:06 PM.
#3 Old Jan 10th, 2007, 09:55 PM
Sorta-Newbie
 
Join Date: Oct 2005
Location: Cincinnati
Posts: 18
Thanks for the reply.

I have put the front of the car on ramps, and let it idle for like 15 minutes with the radiator cap off. Then i topped it off with antifreeze and put a new radiator cap on it.

After doing all that, the heat works a lot better. But its still not right, when i stop the heat cools off. It doesn't get cold like it did before.
blacktruckryder is offline  
#4 Old Jan 11th, 2007, 06:25 AM
Nissan Addict
 
LONDONDERRY's Avatar
 
Join Date: May 2004
Location: Londonderry, New Hampshire
Posts: 822
Quote:
Originally Posted by metro273
Sounds to me like you MIGHT have a blown head gasket? This is a common issue with the '02-'04 Altimas with the 2.5s. Take it to a Nissan dealership for a correct diagnosis or you'll do what most people do on here and try to fix it themselves and realize that they can't, so it ends up going to a Nissan dealership anyways...

BTW, Have you correctly bled the trapped air out of the cooling system?
How common?
LONDONDERRY is offline  
#5 Old Jan 14th, 2007, 11:21 PM
Nissan Tech
 
Join Date: Aug 2005
Posts: 182
That depends on what you mean by common. I have seen about 10 cars a year with this problem.
Blacktruckryder, do you hear any gurgling sound when you accelerate? If so, then you may have the stuck air pocket in heater core problem, which doing what you did should fix.
Do the air doors for the AC/Heater system move? Can you hear them move when you switch them from Cold to Hot? Or from Recirculate to Fresh? If you have the Manual AC system, then you may have a problem with the cable that runs from the control to the door.
#6 Old Jan 15th, 2007, 11:13 PM
Sorta-Newbie
 
Join Date: Oct 2005
Location: Cincinnati
Posts: 18
Talking

Quote:
Originally Posted by rps180
That depends on what you mean by common. I have seen about 10 cars a year with this problem.
Blacktruckryder, do you hear any gurgling sound when you accelerate? If so, then you may have the stuck air pocket in heater core problem, which doing what you did should fix.
Do the air doors for the AC/Heater system move? Can you hear them move when you switch them from Cold to Hot? Or from Recirculate to Fresh? If you have the Manual AC system, then you may have a problem with the cable that runs from the control to the door.
I think i just had air stuck in the system. I put the car back on the ramps and let it run a little longer. I think that did the trick. It seems to be working now.

I really don't think i have a blown head gasket. The coolant and oil are both clean, the car has never overheated.

Thanks for the help guys.
blacktruckryder is offline  
#7 Old Dec 3rd, 2011, 11:26 PM
NissanForums Newbie
 
Join Date: Jan 2010
Posts: 1
I own an auto/repair facility in Plainfield, IL. I have an 02 2.5L in the shop as we speak that HAD no heat at an idle. Heat for days above idle/under-load.

SOULUTION: SEE J'S REPAIR AND PERFORMANCE ;-) jk jk.... We back flushed the heatercore. Very simple with the right tool.

RESULT: more then heat then you know what to do with at an idle.

J's REPAIR AND PERFORMANCE
815-556-0027
Plainfield, IL

SORRY FOR BRINGING UP A DEAD THREAD!!!!!!
bebmotorsports is offline  
Reply

  Nissan Forum > Altima/Stanza > L31 2002 - 2006

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Recall R3007; Resurfaces! (02-03 Altima 2.5) vinoAltima2.5 L31 2002 - 2006 72 Jan 16th, 2012 01:17 AM
i need your opinions.. 06 altima.. 2.5 99stxsentra L31 2002 - 2006 26 Jan 20th, 2006 01:56 AM
2003 ALTIMA 2.5 S CHRIS123 New Member Forum 1 Oct 18th, 2005 01:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On