P0340 Code - Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old Oct 12th, 2004, 07:51 PM
NissanForums Newbie
 
Join Date: Oct 2004
Posts: 7
P0340 Code

Any little quirks that I need to know about before I change out this distributor? It's an 98 Altima, it started stalling the first code was front oxy sensor, changed that, also gave it a complete tune up,tryed blowing out cam position sensor to see if that helpped, no such luck, all sensor voltage tests showed problem in the dist. So it's down to changing out the dist. any tricks besides the usual, ,marking,rotating to tdc,?

Last edited by poofcan; Oct 12th, 2004 at 08:38 PM. Reason: add more info
Sponsored Links
Advertisement
 
#2 Old Oct 15th, 2004, 10:36 AM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Join Date: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
nope nothing at all. just try and set the distributor in the same position that the old one came out. that way timing will still be close. then adjust the timing and youre set. the distributors on our cars have a slotted key where they meet the cam. it can only go in one way. rotate the rotor where you need to to match the key up.
#3 Old Oct 18th, 2004, 08:40 PM
NissanForums Newbie
 
Join Date: Oct 2004
Posts: 7
Question no codes now

Thanks, changing the dist was no problem and it helped some of the problems, yes i did say some but then it started doing the same thing again stalling out when I come to a stop, so i changed the fuel pump and the filter again, now it stalls out even when I'm in park, but only part of the time short of dumping it in the river( yes it has crossed my mind)any other things I should look at? There are no codes... I am sure glad that there are forums like this for all of us that are geared for the pre 74 cars,, oh yes those were the days..........
#4 Old Oct 18th, 2004, 10:50 PM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Join Date: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
check the condition of the two wires on your mass air flow sensor. then check and clean the connector on the mass air flow sensor. two of the biggest problems with an altima are the mass air flow sensors and the distributors. are there any other symptoms during higher rpms that you havent mentioned yet?
#5 Old Oct 19th, 2004, 02:32 PM
NissanForums Newbie
 
Join Date: Oct 2004
Posts: 7
River bound altima

Yes, at higher speeds it is "jittery", last night it was almost "jerking", What about the knock sensor? I ran a pressure test on the regulator it was fine, anyway I understand that they don't give too many problems. Any other suggestions? Tranny switch?
#6 Old Oct 19th, 2004, 08:15 PM
NissanForums Newbie
 
Join Date: Oct 2004
Posts: 7
ok one thing that happened tonight, I got a po325 knock sensor code,my scan tool also listed a knock sensor circuit malfunction, and the 1 sensor? Does this mean the same thing or am I looking at 2 different problems, it's hard enough getting to the darn thing much less having to go in there twice, any suggestions? Contrary to popular opinion I really do like this ride, when it runs, it's soooo fun to drive
#7 Old Jan 3rd, 2009, 04:29 PM
NissanForums Newbie
 
Join Date: Jan 2009
Posts: 1
ok I just went trought this. I would be crusing 72 miles to work and the car started to jerk. Long story short after being towed home 85 miles i've changed the knock sensor and crankshaft sensor. went to start car and it wouldnt. hook code machine up and got a po340 what is that any help please. Read and called auto zone and this car 2002 and under do not have cam shaft sensor. even the book says it. so i dont know if the distubartor would help to change. 2002 and up have the camshaft sensor accourding to the book. The code reads po340 camshaft malfunction bank 1. any help thanks.
severaltries is offline  
Reply

  Nissan Forum > Altima/Stanza > L30 1998-2001 Altima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! 0312 Code - EVAP Problems LCDMAN A32 1995-1999 Chassis 0 Oct 6th, 2004 11:43 AM
MIL on but no OBD code? daemath QG18 1.8L Engine 3 Sep 16th, 2004 08:27 PM
Help, error code 45 (leaky injector???) bast525 SR-Series Engines (DE/VE) 2 Jul 13th, 2004 10:27 PM
Engine miss, stall with code 34 message jocko k U13 1993-1997 Altima 1 Feb 12th, 2004 02:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On