99 Altima service engine soon light after oil change - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Aug 10th, 2011, 09:58 PM Thread Starter
NissanForums Newbie
 
Joined: Nov 2007
Posts: 5
99 Altima service engine soon light after oil change

My 99 Altima's service engine soon light is ON after oil change and about 50 miles driving. This is the second time. Weird. Mechanic scanned error code, but it didn't return any specific error code. Is it possible? Mechanic searched internet and he said EGR valve need to be replaced. I don't know how he knew EGR valve problem without specific code.
What should I do? EGR valve must be changed?
Mechanic reset the code so light is OFF now but I think the light will be on next oil change. Please help me..
Thank you in advance.....
pnaralove is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Aug 10th, 2011, 11:37 PM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 6,604
I would try checking for codes using the diagnostic mode screw on the ECM:

95–99

Turn ignition On.
Turn diagnostic mode selector on ECU fully clockwise and wait until inspection lamps flash. Number of flashes displayed indicates corresponding mode.
Note number of flashes, then immediately turn diagnostic mode selector fully counterclockwise.
If ignition is turned Off during diagnosis, in each mode, and then turned back on again after power to the ECU has dropped off completely, diagnosis will automatically return to Mode I.
For description of modes, proceed as follows:
(Mode I): with engine stopped, system in bulb check state. with engine running, system in malfunction warning state.
(Mode II): with engine stopped, system in self diagnostic results state. with engine running, system in front O2S monitor state.
smj999smj is online now  
post #3 of 8 Old Aug 16th, 2011, 08:53 PM Thread Starter
NissanForums Newbie
 
Joined: Nov 2007
Posts: 5
After searched google, too much engine oil can turn SES light on. Is it true?
I checked engine oil level with dipstick, it reads above H(igh). Should I drain some?
Thanks million !!
pnaralove is offline  
post #4 of 8 Old Aug 17th, 2011, 12:30 AM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 6,604
A little oil over the mark won't set of the SES light. But if it's more than 1/2 a quart, drain some out.
smj999smj is online now  
post #5 of 8 Old Aug 17th, 2011, 11:38 AM Thread Starter
NissanForums Newbie
 
Joined: Nov 2007
Posts: 5
Thank you for your reply.
The mechanic scanned my car and finally got "EGR control solenoid" code.
Is this different from EGR valve? And Do I have to replace (costs $200)EGR control solenoid ASAP?
If not, it will be get severe problem in the future?
Otherwise, I want to try clean it for myself.
How can I clean it?
Thank you again..

Last edited by pnaralove; Aug 17th, 2011 at 11:41 AM.
pnaralove is offline  
post #6 of 8 Old Aug 17th, 2011, 09:50 PM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Joined: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
id check every rubber hose in the egr system first. every time ive seen a failure involving the egr system, theres been a collapsed and gummy hose somewhere in it. usually underneath the solenoid where the most heat is coming from. grab the hose and pinch it - if it feels squishy, replace it.
Asleep is offline  
post #7 of 8 Old Aug 22nd, 2011, 12:17 PM Thread Starter
NissanForums Newbie
 
Joined: Nov 2007
Posts: 5
Thank you. My car broke down last saturday. Alternator burned...
Replaced alternator and battery. Is this caused by SEL or just coincidence?
Today, I checked the hose and one (short and goes to engine part) of them has 2 white lines and there is a thing(like a bean) between the white lines and it looks like blocking the flow. I took out that hose and ckecked the air flow by blowing breath. I felt air flow penerates the hose.
That little thing in the hose is normal (factory installed) or should I remove?
Thank you

Last edited by pnaralove; Aug 22nd, 2011 at 12:26 PM.
pnaralove is offline  
post #8 of 8 Old Aug 23rd, 2011, 12:55 PM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Joined: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
it sounds like its a check valve. see if you can blow air thru it one way and not the other.
Asleep is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Altima/Stanza > L30 1998-2001 Altima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome