300zx starting issues - Nissan Forum
General Z Discussion For General Z discussion

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old May 8th, 2010, 08:42 PM Thread Starter
NissanForums Newbie
 
Joined: May 2010
Location: Toronto, Canada
Posts: 1
300zx starting issues

hey whats going on guys
I just bought a 1990 300zx NA this morning. I know they are known to be hard to maintain but regardless I love the car.

ISSUE:
My problem is first the car wont start, I got a new battery and it turns over like it did with the old battery but still didnt start. After trying for a while it starts but only if I pump gas while I m turning the key. I have to keep giving it gas or it eventually shuts off.

Second when I was bringing it home on the highway I noticed a fair bit of smoke coming from the passenger side (beneath the dash) I m guessing I got an exhaust leak?

any suggestions ??
300zx90 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Dec 15th, 2010, 07:35 PM
NissanForums Newbie
 
verycooljdm's Avatar
 
Joined: Dec 2010
Posts: 8
How much did you get the car for?

I love my Nissan
Nissan Rocks!
verycooljdm is offline  
Reply

  Nissan Forum > Nissan Z > General Z Discussion

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome