RPM unstable - Nissan Forum
GA16DE 1.6L Engine Engine Discussion: 91-99 Sentra, 95-98 200SX, 91-93 NX1600

 
LinkBack Thread Tools Display Modes
#1 Old Aug 24th, 2004, 11:52 PM
NissanForums Newbie
 
Join Date: Aug 2004
Posts: 3
RPM unstable, pls help (B14)

at constant speed (normally 95km/hr), sometimes appear 'tac' sound at speedometer and immediately the gear will shift up automatically and RPM will shoot high.

at very low speed (10km/hr), sometimes again appear 'tac' sound and immediately the engine off by itself.

pls help, anybody.....
Sponsored Links
Advertisement
 
#2 Old Aug 25th, 2004, 12:49 AM
Zac
Not Anymore.
 
Zac's Avatar
 
Join Date: Mar 2004
Posts: 5,014
G'Day! Welcome to NF, I'm Zac. Their are many knowledgable members here on the forum who can help you fix your problem. You actually posted in the new member section which is really the welcome wagon section. We have a Sentra B14 section and a section for all of the engines ever in a Sentra. Posting the question in their would definately get you more responses. Once again, welcome to the board.

PS: Be sure to search before posting any new topics because quite a few have been discussed.

nothing to say
#3 Old Aug 26th, 2004, 03:10 AM
NissanForums Newbie
 
Join Date: Aug 2004
Posts: 3
Hello

Thks a lot.. I will try to find the solution at B14 section u mentioned
#4 Old Aug 26th, 2004, 07:36 AM
Post Freak
 
lshadoff's Avatar
 
Join Date: Nov 2002
Posts: 1,818
Moved to B14
#5 Old Aug 26th, 2004, 03:03 PM
Nissan Enthusiast
 
Join Date: Jul 2002
Location: Cleveland, OH
Posts: 72
Send a message via AIM to nismoweapon
Is your car an auto or manual? Is it the 1.6L or 2.0L?

If it's an auto, it sounds like it could be the torque converter clutch (TCC) dissengaging and re-engaging. If it is coming on at too low of speeds, the TC will no longer be multiplying torque and it could stall the engine. It would be like letting hte clutch out too fast on a manual.

Other items to check would be vacuum leaks, idle control circuitry, or possibly even a sticking EGR can cause problems. More info would be helpful. I'm an ASE Master Tech. I'll do my best.

Erik R.
'99 Sentra SE Limited 2.0L Auto - Daily driver, former autox car
'89 BMW 325i - Racecar
ASE Master Tech. & L1 Adv. Engine Perf.
nismoweapon is offline  
#6 Old Aug 27th, 2004, 12:47 PM
Sorta-Newbie
 
Join Date: Jul 2004
Location: Indiana, West Lafayette
Posts: 13
I'd say TCC malfuction

Quote:
Originally Posted by chaiwc
at constant speed (normally 95km/hr), sometimes appear 'tac' sound at speedometer and immediately the gear will shift up automatically and RPM will shoot high.

at very low speed (10km/hr), sometimes again appear 'tac' sound and immediately the engine off by itself.

pls help, anybody.....
There is Torque Convertor Clutch in your auto tranny.
After your 4th gear.. in fact there is "extra step" which works just like manual 5th gear. If TCC is engaged, There is no power lose from torque convertor becasue mechanical clutch is engaged. However, if the solonoid that controls TCC is not working properly, it would give you sudden change in rpm or engine stall at stop because it basically fails to disengaged the clutch.

Sentra 97 GXE auto 69,000 mi Stock
#7 Old Mar 4th, 2005, 01:24 PM
NissanForums Newbie
 
Join Date: Feb 2005
Posts: 5
Quote:
Originally Posted by chaiwc
at constant speed (normally 95km/hr), sometimes appear 'tac' sound at speedometer and immediately the gear will shift up automatically and RPM will shoot high.

at very low speed (10km/hr), sometimes again appear 'tac' sound and immediately the engine off by itself.

pls help, anybody.....

+++++++...
Hi. Has your can been fixed?i think we have thesame problem. I got a b14 manual, mine actually drops my rpm to 400 when i change gear,....it almost kills the engine.....hope you can help me too....thanks.
timmackey0825 is offline  
#8 Old Mar 4th, 2005, 02:39 PM
NissanForums Newbie
 
Join Date: Feb 2005
Posts: 5
RPM unstable

Hi guys, I got a nissan sentra series 3 manual....my rpm is unstable, when i change gear my rpm suddenly drops to 400 and back to its normal idling which ranges from 800-900+....it almost kills the engine when running.even when i start my engine cold, my rpm pumps to 1500...I had someone check the throttle but they cannot give me the answer on why is it like that...I would apreciate some help here...thanks.
timmackey0825 is offline  
#9 Old Mar 4th, 2005, 03:09 PM
Nissan Enthusiast
 
Join Date: Jan 2005
Location: VA
Posts: 25
Was it really necessary to post this 3 times, maybe more, in multple places?

Patience young grasshoppa!
#10 Old Mar 4th, 2005, 03:10 PM
Nissan Enthusiast
 
Join Date: Jan 2005
Location: VA
Posts: 25
Also, try cleaning your IACV. It tends to be the most common culprit of poor idle/stall problems.
#11 Old Mar 4th, 2005, 04:17 PM
NissanForums Newbie
 
Join Date: Feb 2005
Posts: 5
rpm unstable...

Quote:
Originally Posted by B14 Bomber
Also, try cleaning your IACV. It tends to be the most common culprit of poor idle/stall problems.
can i do this alone?or should i bring it to a shop?i got a GA16DE engine.
timmackey0825 is offline  
#12 Old Mar 4th, 2005, 09:35 PM
Nissan Enthusiast
 
Join Date: Jan 2005
Location: VA
Posts: 25
You should be able to do this on your own. Use the search, it is your friend.
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > GA16DE 1.6L Engine

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Nissan Sentra (Won't Start) dwdrums27 GA16DE 1.6L Engine 13 Nov 9th, 2005 03:12 PM
advanced timing could this be detination Skoodles GA16DE 1.6L Engine 16 Nov 4th, 2004 04:16 AM
SPECS to Compare Compacts sentravis B14 95-99 chassis 3 Oct 26th, 2003 08:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On