Pinging or Knocking engine sounds during acceleration or uphill - Nissan Forum
GA16DE 1.6L Engine Engine Discussion: 91-99 Sentra, 95-98 200SX, 91-93 NX1600

 
LinkBack Thread Tools Display Modes
#1 Old Jun 9th, 2008, 09:05 PM
Nissan Enthusiast
 
Join Date: Sep 2006
Location: Lima, Peru
Posts: 27
Pinging or Knocking engine sounds during acceleration or uphill

Hi. My GA16DE 92 makes this Knocking noise once it reaches normal working temperature. I've check the timing and it is ok 10º. I'm using 90 octanes fuel and even when i use 95 octanes fuel, it starts to knock after running for 30 min. When the engine is cold o has not reach the normal operation temperature, it doesn't make any knocking noise. Any idea what the problem could be please?
Sponsored Links
Advertisement
 
#2 Old Jun 10th, 2008, 12:53 AM
Nissan Fanatic
 
kizer24's Avatar
 
Join Date: Mar 2008
Location: Waco, TX
Posts: 485
Well im new to these engines and cars, but I would say the ECU would prob go into limp mode for any of the major sensors went out. So I would say check the fuel filter, fuel pump, and fuel pressure regulator. If you are running lean those would be a place to start. You should look at the O2 sensor at the same time. I'm not sure how to test them but I believe there is a way. Oh and please anyone else with ideas please help out or add anything I missed.
#3 Old Jun 10th, 2008, 08:32 AM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 3,999
this could be a mechanical problem, maybe a rod bearing. Listen with a long screw driver and open the throttle in short burst. if the knocking is in area of one cylinder and doesn't do this cold only hot when Oil is thin then this is a possibility.
Try adding an octane booster, this would rule out a the normal engine pre-ignition.
Sorry this is all I can think of to add to the above suggestions. Good Luck......

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
#4 Old Jun 11th, 2008, 12:43 AM
Nissan Fanatic
 
Join Date: Nov 2004
Location: Ellensburg,WA
Posts: 322
I have this problem since day one I owned my sentra.Last for 4 years and put almost 100k miles.Kind of annoying but works ok.All kinds of tune up does not solve the problem.
But now it is getting worse...Time to get another engine...
#5 Old Jun 11th, 2008, 07:16 AM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Join Date: Dec 2004
Location: NJ (Philadelphia area)
Posts: 4,145
Several possibilities:
- Make sure the oil level is at the full mark.
- If the noise has a metallic sound to it, then it could be a worn rod/main bearing.
- The oil pressure may be abnormally low. Check it by using a temporary pressure gauge.

KA-T for life, yo!
#6 Old Jun 11th, 2008, 08:29 AM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 3,999
Good suggestions.
Well 100K miles, I don't think its a rod bearing!!
Are you hearing the valve lash clatter ?
GA's don't have hydraulic lifters, shim adjustment.
I would check the valve clearances next.
It should be easy to rule out detonation with octane booster.

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
#7 Old Jun 13th, 2008, 12:41 AM
Nissan Fanatic
 
Join Date: Nov 2004
Location: Ellensburg,WA
Posts: 322
It happens usually if I push the engine harder or it's uphill.Does not have any pinging when it's idling.
Yes actually first I thought it was spark knock,so maybe the timing was retarded.Set the timing right but still got this noise.I always run with full engine oil.
I start to suspect either timing chain guides/tensioners go bad or worn bearings.But anyone of this things will just make me change the engine.This engine is like 230k miles and just not worth putting more money in it unless I have the money to rebuild the whole thing.I have done all kinds of tune up but the noise is still there.Worn engine is the only possibilty I can think of.
The pinging gets worse when it's hot,especially in summer.
#8 Old Jun 13th, 2008, 08:31 AM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Join Date: Dec 2004
Location: NJ (Philadelphia area)
Posts: 4,145
Probably carbon buildup in the combustion chambers is causing pre-ignition.

KA-T for life, yo!
#9 Old Jun 14th, 2008, 12:50 AM
Nissan Enthusiast
 
No-Pain's Avatar
 
Join Date: Jun 2007
Location: Finland, Hamina
Posts: 86
Send a message via MSN to No-Pain
Complete fuel system cleaner might help because it's supposed to clean fuel system and also vents and combustion chamber. In finland we have for repair shops professional use liquid called forte fuel system cleaner. It's quite like the best available on the market. Try that and hopefully it removes some carbon buildups. Assumpting that knocking is because pre-detonation.

- No-Pain -

Nissan Almera (equal to Sentra) 1997 1.6 litres
Mods so far:
-Added disc brakes to rear
-All corners have got new springs and shock absorbers (monroe reflex)
-custom made 4-->1 exhaust manifold with 2" piping -Some cool kameleont painting
-Head work done. Porting, some valve job (lightening, cleaning and polishing). Intake- and exaustports on the head totally re-designed and grinded.
-Some gauges: oil temp, oil pressure, fuel pressure, meter, lambda and external rev. meter with change ligth
-Free flow air-filter (calculated intake pipe lenght) with CAI.
-Lightened battery, moved to back

- No-pain -
#10 Old Sep 16th, 2008, 05:29 PM
NissanForums Newbie
 
Join Date: Sep 2008
Location: Panama, REp. of Panama
Posts: 1
Quote:
Originally Posted by IanH View Post
Good suggestions.
Well 100K miles, I don't think its a rod bearing!!
Are you hearing the valve lash clatter ?
GA's don't have hydraulic lifters, shim adjustment.
I would check the valve clearances next.
It should be easy to rule out detonation with octane booster.

Hi, I apologize for coming in to this thread so late. I am having almost the same situation as the person how started this thread with a 1994 Sentra GA16DE. The difference may be that I am in Panama and we always have hot weather. I was wondering if you could illustrate me on the Items you mention e.g. Valve lash clatter, Shim adjustment, etc.
Please help in anyway possible.
#11 Old Sep 16th, 2008, 11:37 PM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 3,999
download the Factory service manual its free at phatg20.net
I think the engine above with 230K miles needs new chains and at that mileage maybe not worth it as low mileage replacements are relatively in-expensive.
Check your timing and try if its still making noise add Octane booster. it it doesn't stop its not detonation. We have knocksensors anyway, so i don't think the engine will knock due to pre-ignition.
Your first suspect should be the upper timing chain tensioner and guides if you are above 120K miles ( not Km) they seem to go bad, your mileage will vary!!

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > GA16DE 1.6L Engine

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On