OBDII P0340 & P0400 - Nissan Forum
GA16DE 1.6L Engine Engine Discussion: 91-99 Sentra, 95-98 200SX, 91-93 NX1600

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jan 9th, 2007, 04:37 PM Thread Starter
NissanForums Newbie
 
Joined: May 2006
Location: Norfolk, VA
Posts: 9
OBDII P0340 & P0400

I read my OBDII and got codes P0340 & P0400
Something to do with the Exhuast gas recirculation (p0400) and cam position sensor A (p0340). What is causing me to lose speed and cause my car to choke at 3000 rpm

....the story continues
smacktime is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jan 25th, 2007, 04:37 PM
I Live Here
 
IanH's Avatar
 
Joined: Feb 2003
Location: Richardson Tx
Posts: 4,002
Quote:
Originally Posted by smacktime
I read my OBDII and got codes P0340 & P0400
Something to do with the Exhuast gas recirculation (p0400) and cam position sensor A (p0340). What is causing me to lose speed and cause my car to choke at 3000 rpm
I have the P0400 code, EGR and EGR temp sensor.
I searched here (hint hint) and found that the rubber hose under the EGR-BPT falls apart and is a common cause.
Sure enough mine was rotten and had a hole, this is a small hose with a right angle bend. I tried a straight hose replacement but it collapsed.
From the dealership this was part 14755-0B701 at 10.79 list.
Replaced it but have not reset the ECU or done enough miles and restarts to reset it yet.
Hope this helps.

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
IanH is offline  
post #3 of 3 Old Feb 8th, 2007, 07:12 PM
I Live Here
 
IanH's Avatar
 
Joined: Feb 2003
Location: Richardson Tx
Posts: 4,002
Quote:
Originally Posted by IanH
I have the P0400 code, EGR and EGR temp sensor.
I searched here (hint hint) and found that the rubber hose under the EGR-BPT falls apart and is a common cause.
Sure enough mine was rotten and had a hole, this is a small hose with a right angle bend. I tried a straight hose replacement but it collapsed.
From the dealership this was part 14755-0B701 at 10.79 list.
Replaced it but have not reset the ECU or done enough miles and restarts to reset it yet.
Hope this helps.
Well the CEL finally went off today, it took 14 days !!!!

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
IanH is offline  
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > GA16DE 1.6L Engine

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL: code P0400 (EGR Flow Malfunction) jumpr New Member Forum 16 Aug 20th, 2013 02:39 PM
GA16de Mass Airflow Sensor smacktime GA16DE 1.6L Engine 5 Jan 9th, 2007 09:04 AM
P0400, P1400, P0500 Codes Tag B14 95-99 chassis 7 Sep 5th, 2006 06:19 PM
p0340 jgeorger A33 2000-2003 Chassis 2 Jan 9th, 2006 06:48 PM
OBDII? tme1129 S14 240SX 1995-1998 6 Jun 7th, 2005 01:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On