Idle Problems - Nissan Forum
B14 95-99 chassis 1995-1999 Sentra and 1995-1998 200SX

Reply
 
LinkBack Thread Tools Display Modes
#1 Old Jun 17th, 2004, 06:36 PM
NissanForums Newbie
 
Join Date: Jun 2004
Posts: 1
Question Idle Problems

I have a 1997 Nissan Sentra, Just recently when I slow don or stop with the AC on the engine cuts off. In addition if i'm at idle the engine will cut off. If I turn the AC off the engine runs fine. Does anyone know what could be causing this? Thanks Wenwind
Sponsored Links
Advertisement
 
#2 Old Jun 18th, 2004, 10:37 PM
Cone Dodger
 
azkicker0027's Avatar
 
Join Date: May 2002
Location: Houston, Texas y'all...
Posts: 3,081
Send a message via AIM to azkicker0027
so you're saying that the car stalls with the AC on?? common cause is a faulty idle air control valve. does the rpm dip very low when coming to a stop, then die??

Naturally aspirated autocross car.............naturally.
http://www.cardomain.com/id/azkicker0027 Retired STF champ car.
http://shop.3bspecialties.com/main.sc
http://www.facebook.com/azkicker0027
azkicker0027 is offline  
#3 Old Jun 20th, 2004, 08:53 PM
Nissan Enthusiast
 
Join Date: Mar 2004
Location: NH
Posts: 66
yeah, it doeson mine too.
bryan

-1995 Nissan 200SX SE-R-
Ractive Air filter, 2.5" Megan Racing cat-back exhaust system, "Custom" short shifter.
BryanC 95SE-R is offline  
#4 Old Jun 21st, 2004, 12:13 PM
Nissan Enthusiast
 
Join Date: Oct 2002
Posts: 47
It's probably the Air Regulator which is below the IACV. It's a square with two adaptors for hoses on each side, with the square part in the middle. I am pretty sure that the Air Regulator controls (raises) the idle when the AC or other heavy loads are on.
#5 Old Jun 26th, 2004, 08:34 AM
Nissan Enthusiast
 
Join Date: May 2004
Posts: 58
use wd 40

this was told to me by a nissan engineer not a mechanic but an engineer

there is a sensor on the throttle body held by two scews if you are in front of the car it is right in the middle the screws are facing the firewall
it is right on top on the TB close to the plastic intake
anyways take it out unplug the harness that it is attached to then just use wd 40 on it , i usually wd 40 the hole too
dry it up then put it back idle should be good as new
been doing it a while and it works...i've done it 4-5 times already
car has 189k miles
#6 Old Jun 26th, 2004, 10:30 PM
Im out of here!!!!!!!!!!
 
Join Date: Jun 2002
Location: **********.com
Posts: 2,222
I had the same problem a few years back. I cleaned the IAC valve, and the problem was gone. Still no problems to date.
This is the IAC valve in Red:
Nostrodomas is offline  
#7 Old Jul 16th, 2004, 08:30 AM
Sorta-Newbie
 
jeffdano's Avatar
 
Join Date: Aug 2003
Location: Chandler, AZ
Posts: 22
Quote:
Originally Posted by Nostrodomas
I had the same problem a few years back. I cleaned the IAC valve, and the problem was gone. Still no problems to date.
This is the IAC valve in Red:

Yes, it is 99% likely to be the IAC, this was recommended to me a few months ago (believe I owe thanks to Nostrodomas). You could, if you have the patience, do it yourself, very easy to do with some carb cleaner and a lint-free rag. Haven't had a stall out or issue with AC all summer... thank God because I'm in the freakin' desert!

-jeffdano
#8 Old Jul 16th, 2004, 08:09 PM
Im out of here!!!!!!!!!!
 
Join Date: Jun 2002
Location: **********.com
Posts: 2,222
Good to hear it fixed your problem Jeff...
Nostrodomas is offline  
#9 Old Jul 19th, 2004, 04:51 PM
NissanForums Newbie
 
Join Date: Jul 2004
Posts: 4
I had this same thing happen to me and I had to replace the idle control valve...
#10 Old Aug 24th, 2004, 10:33 PM
Nissan Enthusiast
 
Join Date: Oct 2002
Posts: 67
I have a 1996 sentra with 90 k in mileage.

Over the past couple of months i have noticed an extremely rough idle on cold starts. Once the car is running it is fine as well as starting after it is warmed up.
I plan on replacing the fuel filter this week, is this a sign of an O2 sesor on its way out?

What else might cause this? Plugs and wires were just replaced..

Thanks for your help
#11 Old Aug 24th, 2004, 11:56 PM
Im out of here!!!!!!!!!!
 
Join Date: Jun 2002
Location: **********.com
Posts: 2,222
Quote:
Originally Posted by jeffdano
Yes, it is 99% likely to be the IAC, this was recommended to me a few months ago (believe I owe thanks to Nostrodomas). You could, if you have the patience, do it yourself, very easy to do with some carb cleaner and a lint-free rag. Haven't had a stall out or issue with AC all summer... thank God because I'm in the freakin' desert!

-jeffdano
Nostrodomas is offline  
#12 Old Aug 25th, 2004, 09:24 PM
Nissan Enthusiast
 
Join Date: Oct 2002
Posts: 67
Quote:
Originally Posted by Nostrodomas
The iac is the thing covered in the black plastic correct? When i unbolt that is it going to fly apart or is it fairly easy to take off and then put back on?
#13 Old Aug 26th, 2004, 07:15 PM
Im out of here!!!!!!!!!!
 
Join Date: Jun 2002
Location: **********.com
Posts: 2,222
Yes, all you need to do is unplug the sensor. Then take a large phillips screwdriver, and remove the two screws that thread into the throttle body. Nothing is going to fall apart. You do want to go easy on the gasket, if your gentle enough you can reuse it.
Once you get it off, the sensor looks like two cylinders, one inside of each other. The outer one turns, to reveal an opening in the two cylinders. What you want to do is, get some thinner, or gas, brakeclean, and clean the two cylinders. Especially where the slot is made when turning the outer cylinder. Damnitt im getting tired of typing cylinder........lol
Nostrodomas is offline  
#14 Old Aug 26th, 2004, 09:51 PM
Nissan Enthusiast
 
Join Date: Oct 2002
Posts: 67
Ill give that a try next. I just replaced the O2 sensor, PCV, Plugs, Wires, Dist cap, and Battery. Good old refresher so we shall see.
#15 Old Aug 27th, 2004, 12:33 PM
Sorta-Newbie
 
Join Date: Jul 2004
Location: Indiana, West Lafayette
Posts: 13
pcv valve.. ground wire.. fuel pressure check

Quote:
Originally Posted by wenwind
I have a 1997 Nissan Sentra, Just recently when I slow don or stop with the AC on the engine cuts off. In addition if i'm at idle the engine will cut off. If I turn the AC off the engine runs fine. Does anyone know what could be causing this? Thanks Wenwind
You can try to replace your pcv valve.. check ground wires.. and also check fuel pressure... and fuel filter
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > B14 95-99 chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
idle problems tdee Truck & SUV 4 May 27th, 2008 05:18 PM
87 Kingcab with idle problems & introduction Warped Truck & SUV 4 Sep 10th, 2004 06:23 AM
TPS location and idle problems Jaralaccs GA16DE 1.6L Engine 1 Jun 8th, 2004 10:40 AM
idle problems.. L0sT S13 240SX 1989-1994 1 Apr 1st, 2003 08:31 AM
More idle problems ( 90 Sentra) Tom F GA16DE 1.6L Engine 0 Jul 14th, 2002 08:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On