rpm drops when AC engage - Nissan Forum
B14 95-99 chassis 1995-1999 Sentra and 1995-1998 200SX

 
LinkBack Thread Tools Display Modes
#1 Old Sep 1st, 2008, 09:03 PM
Sorta-Newbie
 
Join Date: Sep 2008
Posts: 20
rpm drops when AC engage

good day to all the members, I am newbie here, may I know what is the cause of my cars idle dropping when the aircon engage? at idle with no AC, rpm is at 750, when I turn on the AC, it would drop to 450 to 500 rpm that causes the engine to shake and it return immediately to 750 rpm. I am thinking of the FICD or AAC valve that is not working. Please help, its uncomfortable if engine is shaking everytime the aircon engage to on. thanks
Sponsored Links
Advertisement
 
#2 Old Sep 1st, 2008, 09:16 PM
Nissan Enthusiast
 
Join Date: Aug 2008
Location: Was Orlando; Now Central VA
Posts: 78
Garage
Is this when u first start her up or after she's warmed up? The engine shakes when the AC is kicked on? Is this just your sensing the condensor kicking on? The AC is going to draw on this engine hard - it is rather underpowered until it warms up for the AC.

Couple other thoughts - check the timing - 750 to 450 sounds odd to me unless engine is cold. Also - have u checked the spark plugs?
GreenEyedAngel is offline  
#3 Old Sep 2nd, 2008, 03:43 AM
Sorta-Newbie
 
Join Date: Sep 2008
Posts: 20
yes after the car has been warm up, temp is already at the mid pointer, the idle is 750 or sometimes at 700. its unstable. And when i finally push the AC button to on position, the rpm drops quickly to around 500, sometimes 450 and it goes up quickly to its 750 rpm position. the dropping of the rpm causes the engine to shake when reaching to 500 rpm. is there a way that would increase the rpm at least 800 when I turn the AC on? would be the dropping of rpm be avoidable? i just read the work of the FICD and the AAC valve that they will increase more air meaning increasing the idle during AC on, headlights on, turning the sterring wheel, and others. so that the dropping would be avoidable and also the trembling of the engine. please advice, thank you in advance
#4 Old Sep 2nd, 2008, 03:46 AM
Sorta-Newbie
 
Join Date: Sep 2008
Posts: 20
and yes the spark plugs are ok, thanks
#5 Old Sep 2nd, 2008, 11:21 AM
Nissan Enthusiast
 
Join Date: May 2006
Posts: 32
Take your IAC valve off and give it a thorough cleaning with carb/injector cleaner. Most probably it'll cure your problem.
#6 Old Sep 3rd, 2008, 03:09 AM
Sorta-Newbie
 
Join Date: Sep 2008
Posts: 20
thanks topz, i will try to do what you had suggested, thanks
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > B14 95-99 chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On