Odometer and trip meter don't work correctly..what do I do? - Nissan Forum
B14 95-99 chassis 1995-1999 Sentra and 1995-1998 200SX

 
LinkBack Thread Tools Display Modes
#1 Old May 28th, 2007, 09:06 PM
NissanForums Newbie
 
Join Date: May 2007
Posts: 3
Odometer and trip meter don't work correctly..what do I do?

I have a 1995 Nissan Sentra GXE. I just bought it today as a replacement for my 2001 Mitsubishi Mirage. It's only my second car.....Uhm, my Mitsubishi had a digital odometer and this one has the one that rolls the numbers. Now, I'm not very car savvy, but I know the odometer and trip meter are supposed to move with every mile, but. it *isnt*. It would move every once in a while, but thats after I know for sure that I went farther than that. What would I do to go about fixing the problem, or what could the problem be? is it as simple as the button is jammed (but i dont see how the odometer would stop working too if thats the case) or is it as complex as i would need to replace the whole odometer thingy? (which of course, i dont know how to go about doing that -_-) Has anyone else had this problem? I'm sorry for sounding kinda dumb, as I said I'm not too good with cars though I'd like to be.

thanks for the help and I hope I didnt confuse you with my ranting explanation!

~quirky_rikku
quirky_rikku is offline  
Sponsored Links
Advertisement
 
#2 Old May 28th, 2007, 10:00 PM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 4,000
Quote:
Originally Posted by quirky_rikku
I have a 1995 Nissan Sentra GXE. I just bought it today as a replacement for my 2001 Mitsubishi Mirage. It's only my second car.....Uhm, my Mitsubishi had a digital odometer and this one has the one that rolls the numbers. Now, I'm not very car savvy, but I know the odometer and trip meter are supposed to move with every mile, but. it *isnt*. It would move every once in a while, but thats after I know for sure that I went farther than that. What would I do to go about fixing the problem, or what could the problem be? is it as simple as the button is jammed (but i dont see how the odometer would stop working too if thats the case) or is it as complex as i would need to replace the whole odometer thingy? (which of course, i dont know how to go about doing that -_-) Has anyone else had this problem? I'm sorry for sounding kinda dumb, as I said I'm not too good with cars though I'd like to be.

thanks for the help and I hope I didnt confuse you with my ranting explanation!

~quirky_rikku
I assume the speedo is working ok.
If so then the odo is probably broken, i suggest a used cluster. they go for 40 -50 $
Look on web and find one near you with the same mileage.
If you don't find one with the same mileage go to the Nissan dealer they have a sticker to add to the door jamb that they fill out with the correction.
good luck...
BTW you need the same kind ie no tach, security if you have it etc.
you will have to rewire the plugs if you upgrade to a cluster with a tach from without a tach.

there are instruction on how to do this.

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
#3 Old May 28th, 2007, 10:10 PM
NissanForums Newbie
 
Join Date: May 2007
Posts: 3
Quote:
Originally Posted by IanH
I assume the speedo is working ok.
If so then the odo is probably broken, i suggest a used cluster. they go for 40 -50 $
Look on web and find one near you with the same mileage.
If you don't find one with the same mileage go to the Nissan dealer they have a sticker to add to tech door jamb that they fill out with the correction.
good luck...
BTW you need the same kind ie no tach, security if you have it etc.
you will have to rewire the plugs if you upgrade to a cluster with a tach from without a tach.

there are instruction on how to do this.
well as far as i know my speedometer works.....how will i know if it isnt working? i can pretty much visually tell how fast im going, but at faster highway speeds i cant tell so much. i just know that at 70 i seem to pass cars in the slow lane...as if im going almost 80..but thats probably just people going slow, haha. and no i dont have a tachometer or anything like that.

i'll probably have my brother look at it, he has a 1998 altima. but i will take your advice, ive been looking to see what i can find pertaining to this matter..thank you
quirky_rikku is offline  
#4 Old May 29th, 2007, 10:21 AM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 4,000
Quote:
Originally Posted by quirky_rikku
well as far as i know my speedometer works.....how will i know if it isnt working? i can pretty much visually tell how fast im going, but at faster highway speeds i cant tell so much. i just know that at 70 i seem to pass cars in the slow lane...as if im going almost 80..but thats probably just people going slow, haha. and no i dont have a tachometer or anything like that.

i'll probably have my brother look at it, he has a 1998 altima. but i will take your advice, ive been looking to see what i can find pertaining to this matter..thank you
yes if its reading then its working. That means the pick up is OK on the transaxle.
I swapped my cluster out for one with a tach.
You have to re-wire all three plugs in the cluster. No going back easily.
biggest problem is if you have an issue with something not working, is it the new wiring job or the used cluster ?
I tested my used cluster in daughters SER before attempting the re-wiring.
Search for cluster swap. there is a good write up by ninety - nine sel ( Justin) on his web site with links on the forum here.
If i can find it I will add later.
Good Luck....

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
#5 Old May 29th, 2007, 01:54 PM
NissanForums Newbie
 
Join Date: May 2007
Posts: 3
Thanks...

if i do replace the cluster thing, ill probbaly get one identical to the one I have for good measure....

oh and i have an update. today, my odometer worked but only rolled to a new number every 20 minutes i was driving or so, and my trip meter..it would work for a sec, stop working, start again...and right now it reads that I went 7 miles. but i know i went at least 30. XD
quirky_rikku is offline  
#6 Old May 29th, 2007, 03:22 PM
I Live Here
 
IanH's Avatar
 
Join Date: Feb 2003
Location: Richardson Tx
Posts: 4,000
Quote:
Originally Posted by quirky_rikku
Thanks...

if i do replace the cluster thing, ill probbaly get one identical to the one I have for good measure....

oh and i have an update. today, my odometer worked but only rolled to a new number every 20 minutes i was driving or so, and my trip meter..it would work for a sec, stop working, start again...and right now it reads that I went 7 miles. but i know i went at least 30. XD
Ok good luck, i think if the speedometer works fine then its just the ODO
BTW fill in your particulars so we can see where you are and your car etc.
I find it helps sometimes.

2003 Pathfinder from 2004 SE 4WD
1997 SER 5sp Manual from new Rear Ended 2009 !!
Gone to the Knacker yard...
New ride 3.0 manual RWD not a Nissan !!!
1997 Sentra GXE from new .... Sold 2008
2001 Sunny N16 RHD from new (N16 Nissan Bluebird Sylphy) Sold
#7 Old May 31st, 2007, 02:01 AM
Sorta-Newbie
 
Join Date: Jul 2006
Posts: 14
i have a similar problem, but my odo works when it is cold out and stops as summer arrives
#8 Old May 31st, 2007, 02:01 AM
Sorta-Newbie
 
Join Date: Jul 2006
Posts: 14
maybe it is a line that warps in heat?

Last edited by xomiax; May 31st, 2007 at 02:05 AM.
#9 Old May 31st, 2007, 11:58 AM
Nissan Fanatic
 
Burn 17's Avatar
 
Join Date: Nov 2004
Location: Elk Grove Callifronia
Posts: 467
Send a message via MSN to Burn 17
ya mine is very simmilar, works normaly for a while then stopps, then some times it spinns hella fast to catch up for the time it didnt work, but my vss also has malfuncutiond as well a few times, altho my gps tells me that my spedo works fine

NEW!!1987 300ZX
200 sx auto cross beast--

Intake, Front and Rear Strut bars, Major exhaust leak.98style tail lights, clear corners, and halo angle eyes, Hot Shot headers/Downpipe(still need money for the rest of it)


Mazda B2200 Mini Truck
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > B14 95-99 chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer not working BlackedOutAltima U13 1993-1997 Altima 13 Dec 19th, 2007 05:32 PM
trip odometer and odometer, sticking,need fix? hardbodyfixer Truck & SUV 1 Dec 24th, 2005 07:05 PM
trip, odometer not working...? help... ProjectH213 S13 240SX 1989-1994 0 Dec 27th, 2004 06:47 PM
trip odometer ticking sfhellwig B14 95-99 chassis 4 May 3rd, 2004 11:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On