Battery & Brake light on. Replaced Alternator, what else? - Nissan Forum
B13 91-94 chassis 1991-1994 Sentra and 1991-1993 NX

 
LinkBack Thread Tools Display Modes
#1 Old Jul 26th, 2010, 09:54 AM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
Battery & Brake light on. Replaced Alternator, what else?

Both the battery and brake light are coming on. I replaced the alternator with a new one. And after first starting it up we got a little smoke coming from the battery wire (no battery/brake light at this point). We attributed this to some oil being on the wire. Re-tightened and smell and smoke went away. Drove it a little yesterday and still no warning lights. Coming in to work this morning the warning lights came on, can hear relay switch ticking when they come on. Had battery tested while identifying shot alternator it had a charge of 11.2 Don't know where to go from here. Belts should be at right tension and install went well. What should I trouble shoot? Thanks.
Sponsored Links
Advertisement
 
#2 Old Jul 26th, 2010, 01:37 PM
Sorta-Newbie
 
Join Date: Jul 2010
Location: Miami
Posts: 13
did u make sure that its the right alternator for ur car?
#3 Old Jul 26th, 2010, 02:07 PM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
I'll double and triple check that it's the right one. But in order to avoid the core cost I brought the old one in and compared the two. My optimistic thought on this is that the belt tension is too little or too much. It's an easy job so removing and replacing if needed isn't a hassle.
#4 Old Jul 26th, 2010, 09:03 PM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
Tightened the belt, drove a little bit. Still having the light come on. When my rpm's are up the lights go away. I've noticed no loss in power via the lights, stereo, or a/c. But have noticed the power steering having a little less "power" having to work a little harder to turn. Am I looking at a bad replacement alternator? Didn't buy the cheap one but didn't by the most expensive on either. I've searched the forums and have probably found my problem is the alternator but, IT'S SO HOT HERE I DON'T WANT TO GO UNDER THE HOOD AGAIN!!!!!I appreciate any input.
#5 Old Jul 26th, 2010, 11:27 PM
Nissan Addict
 
tlhingan's Avatar
 
Join Date: Jun 2009
Posts: 616
How old is your battery?
Test the output voltage at the alternator, it might be over or undercharging.
If the alternator output is fine, test the output voltage at the battery,
It it's not right you may need a new battery.

94 B13X | UR underdrive pulley
PaceSetter header | K&N filter
Rear drum to Maxima disc conversion
#6 Old Jul 27th, 2010, 10:03 AM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
Battery was purchased 9/03/09. The failing alternator could have really hurt it. Fortunately I work next to O'reilly's , so the battery is with me. I'll have it tested but I'm not wanting to drive the car the 8miles to and the 8miles back from here if the alternator is bad. I have a multimeter but not really sure how it works. Tried testing the battery with it but was getting more sparks than I was comfortable with.
#7 Old Jul 27th, 2010, 01:50 PM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
Battery was low, took it to the store and had it charged. We'll see where this leads us.
#8 Old Jul 29th, 2010, 10:00 AM
Nissan Enthusiast
 
Join Date: Jul 2009
Posts: 35
It was of course the alternator. Took it in for testing and it failed all three tests they ran. The second install was quite easy, about 15mins not counting belt tension. So far so good.
#9 Old Jul 29th, 2010, 10:16 AM
Sorta-Newbie
 
Join Date: Jul 2010
Location: Miami
Posts: 13
congrats dude
#10 Old Aug 4th, 2010, 12:42 PM
Nissan Enthusiast
 
SE_RBOY's Avatar
 
Join Date: Jul 2010
Location: SC, UNITED STATES
Posts: 102
Send a message via AIM to SE_RBOY Send a message via Yahoo to SE_RBOY
i changed my alternator and its fine. i bought a manufactured 1. exactly for my car. I no longer have any problems with it. battery light went off. Starts fine everyday. All the dash lights are still bright with a strain on the battery. But you mite have the wrong alternator.
#11 Old Aug 4th, 2010, 12:42 PM
Nissan Enthusiast
 
SE_RBOY's Avatar
 
Join Date: Jul 2010
Location: SC, UNITED STATES
Posts: 102
Send a message via AIM to SE_RBOY Send a message via Yahoo to SE_RBOY
or a bad battery or cables
#12 Old Aug 4th, 2010, 12:51 PM
Nissan Enthusiast
 
Join Date: Mar 2010
Location: California
Posts: 223
It's a common problem for the alternators purchased at the budget priced auto parts stores to go bad in a very short period of time. You get what you pay for.
NissanPartsDept is offline  
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > B13 91-94 chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On