Weird noise coming from under my 95 Maxima - Nissan Forum
A32 1995-1999 Chassis 1995-1999 Maxima

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jun 19th, 2005, 07:28 PM Thread Starter
NissanForums Newbie
 
Joined: Jun 2005
Posts: 2
Weird noise coming from under my 95 Maxima

I have a 95 Maxima GLE, 123k miles.

Recently after having my brake pads changed, I noticed a TERRIBLE grinding noise coming out of what seemed like my front right tire. It made the noise occasionally, when I lightly tapped on the brakes. I had the rotors cleaned, then changed the brakes pads out again. That still did not help! Now I've begun to realize the noise is there when I apply the brakes, but also seems like its there when I TURN the steering wheel, but at a lower more constant volume. I am pretty sure its not my brake pads now.

I'm beginning to suspect maybe the struts or the CV joints? Any ideas?

Thanks!
thechoson is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jun 20th, 2005, 01:04 AM
Will work for beer
 
Joined: Sep 2003
Location: Pearland, TX
Posts: 2,696
check the metal dust sheild and see if it's rubbing against the rotor. it's common to see after work is done on/around the suspension.
if it's rubbing, simply bend it back away from the rotor a bit and that's all you have to do.

My website.
Quote:
Originally Posted by Radioaktiv
you guys are picky as shit for internet nerds
Matt93SE is offline  
post #3 of 5 Old Jun 20th, 2005, 01:34 AM Thread Starter
NissanForums Newbie
 
Joined: Jun 2005
Posts: 2
I am sorry, I am a bit of a moron about these things.

What exactly is the metal dust shield, and where do I find it, I am assuming it's somewhere around the tire, and by bending it back, is this something I can just forcefully pull back by hand, or will I have to bang it back with a hammer or something?
thechoson is offline  
post #4 of 5 Old Jan 27th, 2008, 11:21 PM
NissanForums Newbie
 
Joined: May 2007
Posts: 5
if you take your tire off and look at the rotor (the big circular thing that the break bads clamp onto when breaks are applied) there is a piece of metal that come from behind and then comes out over the top and the side slightly that part is the dust shield. one thing that you should also look at if that doesnt appear to be the problem is the rubber boot on the half shaft. after time that rubber gets dryrotted and begins to crack. when it does this it looses all the grease within the rubber boot as you drive and it makes a grinding noise while you're driving
BarkerMi129 is offline  
post #5 of 5 Old Feb 7th, 2008, 08:38 PM
NissanForums Newbie
 
Joined: Feb 2008
Posts: 1
I had a customer the other day with a older Sentra with about the same complaint. After two tries, I was about to blame the hub bearing when a friend walked by and noticed an air deflector rubbing the axle. Although it was plastic, it made a terrible grinding noise. I cut a small relief in it-problem solved.

John

Last edited by john_al; Feb 7th, 2008 at 08:39 PM. Reason: clarification
john_al is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Maxima > A32 1995-1999 Chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noise TMWTMP100 Audio 9 May 18th, 2004 07:23 PM
weird exhaust noise? Tickwomp Naturally Aspirated 6 Sep 2nd, 2003 02:47 AM
Weird Noise d_meist GA16DE 1.6L Engine 1 Aug 29th, 2003 11:50 AM
weird noise the don 1600 Suspension & Brakes 8 Apr 24th, 2003 10:48 PM
wierd noise coming from the engine mayco SR-Series Engines (DE/VE) 10 Jan 8th, 2003 11:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome