Knock sensor problem???? - Nissan Forum
A32 1995-1999 Chassis 1995-1999 Maxima

 
LinkBack Thread Tools Display Modes
#1 Old Aug 1st, 2005, 10:43 AM
NissanForums Newbie
 
Join Date: Jul 2005
Location: brooklyn
Posts: 8
Knock sensor problem????

I have a 1997 maxima, and my service engine light is on, and when I ran the computer it said that I have a Knock sensor problem in bank 1. But the thing is my car runs smoothly. A mechanic told my friend who also has a maxima that the same problem came up, but that wasnt really the problem, the mechanic said in maxima's under 2000; the knock sensor always shows up. If my knock sensor is really disfunctional, what problems or unusual movement should I feel while driving? For the past 2 months since the light is on my car has always been running smoothly. Can someone please help cause pockets are tight now, and I dont want to spend money on a piece if it is not necessary.
Sponsored Links
Advertisement
 
#2 Old Aug 1st, 2005, 12:39 PM
Nissan Enthusiast
 
Join Date: Sep 2004
Location: New York
Posts: 110
A bad knock sensor will not trigger the service engine light, but the code will be there when checking for codes(ghost code). Something else must have triggered the light. Are you sure there are no other codes? I also heard that the knock sensor code will appear along with other codes even if there is nothing wrong with the knock sensor.
#3 Old Aug 11th, 2005, 07:33 PM
NissanForums Newbie
 
Join Date: Aug 2005
Location: Andover, MA
Posts: 1
Knock, Knock, who's there!

Quote:
Originally Posted by MaxQuest
A bad knock sensor will not trigger the service engine light, but the code will be there when checking for codes(ghost code). Something else must have triggered the light. Are you sure there are no other codes? I also heard that the knock sensor code will appear along with other codes even if there is nothing wrong with the knock sensor.
-------------
I've got the exact same thing and am trying to figure out just what caused it(also got P0150--O2 sensor)..I did find a NISSAN service bullitin stateing that the wiring harness voltage inductions may be the issue...I'd send jpg of the image if you tell me how to place a image into this thread!
#4 Old Aug 12th, 2005, 09:33 AM
NissanForums Newbie
 
Join Date: Aug 2005
Location: Boston MA
Posts: 2
Angry

Quote:
Originally Posted by slax
-------------
I've got the exact same thing and am trying to figure out just what caused it(also got P0150--O2 sensor)..I did find a NISSAN service bullitin stateing that the wiring harness voltage inductions may be the issue...I'd send jpg of the image if you tell me how to place a image into this thread!
I have had me 2002 Frontier a week and the Knock Sensor has gone twice. The Dealer has fixed it for free but, now I am thinking Lemmon law and taking it back..
What would you do??
I love the truck but the check engine light is pissing me off..
sox fan 262 is offline  
#5 Old Aug 17th, 2005, 03:52 PM
NissanForums Newbie
 
julyguy's Avatar
 
Join Date: Jun 2005
Location: Winnipeg
Posts: 2
I have the same problem

This is my first post here but i was surprised to see this thread.

I have a 96 Maxima with a little over 182K kilometers on it at present.

In May, the trouble light came on and my mechanic checked the code which read PO325. This indicates a knock sensor or circuit fault. I (foolishly) replaced the sensor which isn't cheap. The code was cleared and the light was out. A week or so later, it came on again and the mechanic found again the same code. I decided to leave it as the car is running fine and I've had no indication of increased fuel use. After 2 weeks it went out.

The damn light came on about a week ago and I'm going to leave it until I get some suggestions as to what is really happening. I'm also guessing that it's a possible wiring harness fault in the line to the PCM.

Does anyone have any ideas?
#6 Old Aug 17th, 2005, 08:09 PM
Nissan Addict
 
Join Date: Feb 2004
Location: California
Posts: 782
Did you replace the wiring harness while he was in there? Often on older cars it corrodes...
#7 Old Aug 18th, 2005, 07:30 AM
NissanForums Newbie
 
Join Date: Aug 2005
Location: Boston MA
Posts: 2
Quote:
Originally Posted by brianw
Did you replace the wiring harness while he was in there? Often on older cars it corrodes...
I finally got my truck back and the did replace the wiring harness. Also, they found a hole in the gas tank, (I'm thinking a gasket had come loose) but they replaced the gas tank and I haven't had any problem since.
sox fan 262 is offline  
#8 Old Jan 19th, 2009, 12:26 AM
Sorta-Newbie
 
Join Date: Dec 2005
Posts: 21
My 2002 Quest van runs for 3 minutes exactly then dies with a pending PO325(Knock sensor).

100% consistent.
jwandhistools is offline  
#9 Old Jun 5th, 2009, 01:31 AM
Sorta-Newbie
 
spetznazer's Avatar
 
Join Date: Jun 2009
Posts: 14
Also check injectors for damage. In my case with Knock Sensor Code it was 3 damaged injectors. Now runs like a champ. Well did now have some other problem either with switch or alarm. Car doesn't start.
#10 Old Jun 8th, 2009, 08:25 AM
NissanForums Newbie
 
Join Date: Jun 2009
Posts: 2
My 1997 has a knock sensor code too. Not sure if related but I had a miss. Found the center rear ignition coil was shorting causing the miss. Swapped it out with a salvage one and it runs smooth again. Have not reset the Check engine light yet but hope to do that today and see if it re appears. I wish I would of wrote them down but my car had 5 different codes when I got it. 2 of which were the knock sensor.
Car runs smooth now!

Last edited by hip001; Jun 8th, 2009 at 08:30 AM.
Reply

  Nissan Forum > Maxima > A32 1995-1999 Chassis

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Knock on Mexican built GA16DE Sentras Pablo14 GA16DE 1.6L Engine 44 Jul 5th, 2006 10:16 PM
HELP -- Putting Gas in 350Z mbarton99 Z33 350Z 2003+ 48 Mar 30th, 2005 06:36 PM
96 Quest with P0325 - engine knock problem jdevera Truck & SUV 4 Dec 20th, 2004 07:09 AM
Engine knock in 2003 at 1800 RPM ?? sjm_mak A33 2000-2003 Chassis 15 Jun 30th, 2004 09:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On